Wikka pages are not styled


Symptoms

Wikka works fine, but all pages appear completely "unstyled".

Cause

There are two possible causes:
  1. Your browser does not support stylesheets or you have disabled stylesheet support.
  2. The rewrite mode configuration is incorrect.

In first case, if your browser does support stylesheets, check that it is enabled; if not, try testing with one that does or ask someone else to do that for you.

In the latter case (when you have made sure stylesheets are supported in the test browser): If the rewrite mode configuration is incorrect the URLs that are used to reference the stylesheets will be incorrect; when requesting a stylesheet the browser will then receive a 404 error to indicate the file is not found and be unable to apply the styling.

Applies to

All versions.

Solution

There is no workaround for a browser that does not have stylesheet support - all styling in Wikka is completely done with stylesheets. Everything will work - it just doesn't look very pretty in some browsers.

If missing or disabled stylesheet support has been eliminated as a cause, use the following cheklist(s):

Wikka 1.1.6.0 and earlier
Use the following checklist for the mod_rewrite configuration
  1. If you use URL rewriting, check your configuration as outlined on ModRewrite (note that there are two parameters and that they must match)
  2. Check that you have the .htaccess file as distributed with Wikka in your base installation directory
  3. Check that the [wikka]/css/ subdirectory contains the .htaccess file as distributed with Wikka (in that subdirectory); it should have the following content:
    <IfModule mod_rewrite.c>
    RewriteEngine off
    </IfModule>


Newer Wikka versions
later

Refinement

maybe


CategoryWorkaround
There are 5 comments on this page. [Show comments]
Valid XHTML :: Valid CSS: :: Powered by WikkaWiki